第一个问题报错原因是: 系统缺少luajit组件,导致nginx使用异常;
解决方法:卸载nginx防火墙/nginx免费防火墙,网站加速。
这些插件没装的话可忽略此步骤,卸载当前版本的nginx,使用编译模式安装一遍nginx1.22,编译安装会自动安装luajit组件; 装好nginx后重装前面卸载的那几个插件即可正常使用。
第二个问题报错原因是:连接不上宝塔公司的节点导致nginx安装异常,可到服务器终端执行此命令修复节点,若还是不行则将执行结果截图发到宝塔官方论坛,待官方解决。
curl -k -sSO https://120.78.156.100/new/auto_node.sh && bash auto_node.sh